livery

Livery: a modern Erlang web framework over HTTP/1.1, HTTP/2, and HTTP/3

Frameworks

Stars

57

Unreleased Activity

First Release

4

months ago

Last Release

18

days ago

Downloads

6.8k

last 90 days

Last Stable Version

0.10.5

Latest Version Downloads

Last 90 Days

Visualizations of the latest version downloads, including both a full list of releases and a view that highlights the main versions.

Version 0.10.5

Published Oct 2026 •
No Elixir Version Requirement Specified
Documentation for 0.10.5

Dependencies

7
erlang_h1 ~>0.9.1

HTTP/1.1 protocol library for Erlang

erlang_ws ~>0.5.0

WebSocket protocol library for Erlang (RFC 6455 / RFC 8441 / RFC 9220)

h2 ~> 0.12.4

HTTP/2 protocol library for Erlang

hackney ~> 4.8.5

simple HTTP client

instrument ~> 1.1.5

Fast metrics library for Erlang with Prometheus export

mimerl 1.5.0

Library to handle mimetypes

quic ~> 2.1.1

Pure Erlang QUIC implementation (RFC 9000)

Community

Looks like this space is still empty… Want to be the first to contribute?

Share an article, talk, or podcast by adding resources to this package.

Related Packages

12 packages