JSON
JSON encoding, decoding, and manipulation libraries. Packages among the 3,000 most downloaded in the past 90 days.
-
1.7k10.1m
-
6961.6m
-
2.0k1.3m
-
169969.6k
-
294285.5k
-
149228.3k
-
70224.3k
-
880221.5k
-
151195.3k
-
jaxon 2.0.8
Jaxon is an efficient and simple event-based JSON parser for Elixir, it's main goal is to be able to parse huge JSON files with minimal memory footprint.
20788.2k last 90 days20788.2k -
21887.2k
-
jesse 1.8.2
jesse (JSon Schema Erlang) is an implementation of a JSON Schema validator for Erlang.
13378.7k last 90 days13378.7k -
jcs 0.2.0
A pure Elixir implementation of RFC 8785: JSON Canonicalization Scheme (JCS).
1272.2k last 90 days1272.2k -
5170.9k
-
540.0k
-
odgn_json_pointer 3.1.0
This is an implementation of JSON Pointer (RFC 6901) for Elixir.
1135.6k last 90 days1135.6k -
13528.6k
-
2828.2k
-
325.9k
-
2925.8k
-
621.6k
-
4520.6k
-
717.6k
-
spectral 0.14.0
Spectral provides type-driven JSON encoding/decoding, JSON Schema generation, and OpenAPI 3.0 specification generation. It uses Elixir's type system to automatically handle serialization based on struct type definitions.
715.5k last 90 days715.5k -
jsonschex 0.10.0
A JSON Schema validator with complete support for the draft 2020-12 and latest specifications.
115.4k last 90 days115.4k -
ex_json_pointer 0.8.0
An Elixir implementation of RFC 6901 JSON Pointer and Relative JSON Pointer.
015.1k last 90 days015.1k -
8512.7k
-
111.6k
-
julienne 1.1.1
A JSON parser that decodes JSON into a flat (non recursive) data structure.
39.7k last 90 days39.7k -
09.2k
-
stable_jason 2.0.0
StableJason is a library for encoding Elixir values to a stable JSON with deterministic sorting for keys.
58.9k last 90 days58.9k -
28.0k
-
torque 0.5.3
High-performance JSON library for Elixir via Rustler NIFs (sonic-rs)
197.5k last 90 days197.5k -
jvalid2 1.0.1
Json Schema validation helper, that allows to store schemes in a separate files.
07.1k last 90 days07.1k -
06.6k
-
json_diff 0.1.3
An Elixir implementation of the diffing element of JSON Patch (RFC 6902)
195.9k last 90 days195.9k -
235.7k
-
rfc8785 1.0.0
RFC 8785 JSON Canonicalization Scheme (JCS) in pure Elixir. Deterministic, byte-exact canonical JSON for hashing and signing. Zero runtime dependencies.
05.3k last 90 days05.3k -
euneus 2.4.0
An incredibly flexible and performant JSON parser, generator and formatter in pure Erlang
275.0k last 90 days275.0k -
404.9k
-
24.9k
-
json_remedy 0.2.1
A blazingly fast Elixir library for repairing malformed JSON using binary pattern matching. Handles LLM outputs, legacy data, and broken JSON with intelligent context-aware fixes.
334.7k last 90 days334.7k -
castor 2.1.0
Work with JSON Schema in Gleam. Supports building schemas as well as encoding decoding from json schema file.
94.6k last 90 days94.6k -
fork_poison 6.0.2
An incredibly fast, pure Elixir JSON library, Forked from Poison Library
04.4k last 90 days04.4k -
json_serde 1.1.1
JsonSerde serializes and deserializes nested elixir datastructures, including custom structs.
124.3k last 90 days124.3k -
jaqex 0.1.5
Wrapper for Jaq (a jq clone focused on correctness, speed, and simplicity)
04.3k last 90 days04.3k -
344.1k
-
jsonpath_ex 0.3.0
A powerful Elixir library for parsing and evaluating JSONPath expressions.
123.5k last 90 days123.5k