Networking

Network programming libraries for sockets, protocols, and network communication. Packages among the 3,000 most downloaded in the past 90 days.

100 packages
  • ranch 2.3.0

    Socket acceptor pool for TCP protocols.

    1.2k
    5.4m last 90 days
  • websock 0.5.3

    A specification for WebSocket connections

    97
    5.2m last 90 days
  • postgrex 0.22.4

    PostgreSQL driver for Elixir

    1.2k
    4.9m last 90 days
  • A simple & modern pure Elixir socket server

    996
    3.8m last 90 days
  • A tcp acceptor pool library

    29
    2.2m last 90 days
  • Simple DNS clustering for distributed Elixir nodes

    248
    2.0m last 90 days
  • Automatic Erlang cluster formation and management for Elixir/Erlang applications

    2.2k
    1.5m last 90 days
  • grpc 1.0.5

    The Elixir implementation of gRPC

    1.5k
    911.8k last 90 days
  • quic 2.1.1

    Pure Erlang QUIC implementation (RFC 9000)

    119
    819.6k last 90 days
  • An Elixir WebSocket client

    11
    784.0k last 90 days
  • WebTransport protocol for Erlang (HTTP/2 and HTTP/3)

    10
    753.9k last 90 days
  • HTTP/1 and HTTP/2 WebSocket support for Mint

    152
    496.3k last 90 days
  • Classless Inter-Domain Routing (CIDR) library for Elixir. Compatible with Erlang's :inet module and support for IPv4 and IPv6

    51
    408.9k last 90 days
  • pfx 0.14.2

    Functions to work with prefixes, especially IP (both IPv4 and IPv6).

    8
    212.2k last 90 days
  • iptrie 0.10.0

    IP lookup, with longest prefix match, for IPv4, IPv6 prefixes (and others).

    19
    211.9k last 90 days
  • Core gRPC types, codecs, and utilities for Elixir

    177.4k last 90 days
  • Fast batch message passing between nodes for Erlang/Elixir.

    1.9k
    170.6k last 90 days
  • A slick websocket client for Phoenix channels

    192
    166.6k last 90 days
  • An Elixir SFTP Client that wraps Erlang's ssh and ssh_sftp.

    53
    114.8k last 90 days
  • Erlang websocket client

    46
    100.8k last 90 days
  • glisten 9.0.1

    a shiny Gleam TCP/SSL server

    98
    97.3k last 90 days
  • IP address and Mac address tools

    25
    72.6k last 90 days
  • Domain / TLD parsing library for Elixir, using the Public Suffix List.

    45
    67.3k last 90 days
  • dns 2.4.0

    DNS library for Elixir using `inet_dns` module.

    115
    55.2k last 90 days
  • fast_tls 1.1.26

    TLS / SSL OpenSSL-based native driver for Erlang / Elixir

    86
    46.9k last 90 days
  • ex_sdp 1.3.0

    Parser and serializer for Session Description Protocol

    9
    38.8k last 90 days
  • ExNudge is a pure elixir library with the purpose of sending Web Push notifications in compliance with RFC 8291. Supports VAPID authentication and payload encryption.

    16
    38.4k last 90 days
  • cidr 1.2.0

    Classless Inter-Domain Routing (CIDR) for Elixir

    46
    37.9k last 90 days
  • socket 0.3.13

    Socket handling library for Elixir

    690
    34.6k last 90 days
  • ex_stun 0.2.1

    Implementation of the STUN protocol

    7
    34.3k last 90 days
  • ex_ice 0.16.1

    Implementation of trickle ICE protocol

    16
    33.2k last 90 days
  • ex_rtcp 0.4.2

    Implementation of the RTCP protocol

    7
    32.8k last 90 days
  • ex_rtp 0.4.1

    Implementation of the RTP protocol

    11
    32.5k last 90 days
  • ex_turn 0.2.3

    In-memory implementation of the TURN client

    5
    32.3k last 90 days
  • Persistent channels, and channel pools for gRPC Elixir

    15
    32.1k last 90 days
  • Support reverse proxying of websocket connections natively in Elixir

    4
    31.7k last 90 days
  • Implementation of the W3C WebRTC API

    482
    29.4k last 90 days
  • Web Push notifications for Elixir

    0
    29.2k last 90 days
  • A simple, no frills mDNS implementation in Elixir

    42
    26.4k last 90 days
  • public_sufx 0.7.20261007

    Operate on domain names using the public suffix rules provided by https://publicsuffix.org/.

    7
    26.1k last 90 days
  • Generated Elixir gRPC contracts for Chronicle

    61
    23.6k last 90 days
  • tortoise 0.10.0

    A MQTT client for Elixir.

    319
    21.3k last 90 days
  • One address DHCP server

    9
    17.1k last 90 days
  • iptools 0.0.5

    A set of functions for validating and transforming IPv4 addresses

    16
    15.8k last 90 days
  • CIDR library for Erlang

    28
    14.3k last 90 days
  • cpool 0.1.1

    A connection-focused worker pool.

    1
    14.2k last 90 days
  • mug 3.1.0

    A TCP client for Gleam!

    38
    13.6k last 90 days
  • Intercluster RPC independent of distribution protocol

    48
    12.6k last 90 days
  • sftp_ex 0.2.6

    A simple SFTP Elixir library

    24
    12.1k last 90 days
  • opuntia 1.1.2

    Traffic shapers for erlang and elixir

    8
    12.1k last 90 days
  • esip 1.0.61

    ProcessOne SIP server component in Erlang

    28
    12.0k last 90 days
  • stratus 3.0.0

    A Gleam WebSocket client

    53
    11.6k last 90 days
  • fresh 0.4.4

    WebSocket client for Elixir, built atop the Mint ecosystem

    63
    10.2k last 90 days
  • Library to create named process in a cluster node and send messages to them.

    1
    9.9k last 90 days
  • pkt 0.6.0

    Network packet parsing library

    154
    8.8k last 90 days
  • Erlang implementation of RAFT Consensus Protocol

    0
    8.4k last 90 days
  • peerage 1.0.3

    Easy clustering, pluggable discovery: via DNS (for Kubernetes, Weave, discoverd, Swarm and others), UDP multicast, or a plain list of nodes. Easy extensibility for custom Providers.

    398
    8.3k last 90 days
  • chumak 1.5.0

    Erlang implementation of ZeroMQ Transport Protocol (ZMTP)

    200
    8.3k last 90 days
  • An IP/Ethernet Utilities library

    13
    8.3k last 90 days
  • elector 0.3.4

    Elects master node from Erlang/Elixir cluster that is agreed by all nodes.

    19
    8.1k last 90 days
  • Erlang/OTP application to throttle/rate limit resource access

    45
    7.5k last 90 days
  • Simple exponential backoffs in Elixir.

    7
    7.5k last 90 days
  • RTSP client for Elixir

    11
    7.3k last 90 days
  • ip 2.1.3

    Represtations and tools for IP addresses and networks.

    0
    7.2k last 90 days
  • ex_sctp 0.1.3

    Elixir wrapper for sctp_proto library

    4
    7.2k last 90 days
  • EPMDLess application (allows connecting erlang nodes without EPMD)

    188
    7.1k last 90 days
  • hackney based WebDAV client.

    4
    7.0k last 90 days
  • quicer 0.4.12

    QUIC transport for beam

    277
    6.9k last 90 days
  • DiodeClient allows direct P2P connection to any other DiodeClient user on the planet using Ethereum Addresses (e.g. 0xb794f5ea0ba39494ce839613fffba74279579268) and BNS names (e.g. yourname.diode) instead of IPv4 or IPv6

    5
    6.9k last 90 days
  • enats 1.2.0

    Erlang NATS.io client library

    6
    6.8k last 90 days
  • WebSocket protocol library for Erlang (RFC 6455 / RFC 8441 / RFC 9220)

    2
    6.8k last 90 days
  • An Erlang DNS message library that supports most common record types, TSIG authenticated messages, EDNS0 and DNSSEC.

    105
    6.7k last 90 days
  • modbux 0.3.14

    Modbus for network and serial communication, this library implements TCP (Client & Server) and RTU (Master & Slave) protocols.

    54
    6.7k last 90 days
  • whois 0.4.1

    Pure Elixir WHOIS client and parser.

    6.4k last 90 days
  • socket2 2.1.3

    Socket handling library for Elixir, updated for OTP20+ by the witchtails team

    12
    6.4k last 90 days
  • ex_wire 0.1.1

    Elixir Client for Ethereum's RLPx, DevP2P and Eth Wire Protocol

    14
    6.0k last 90 days
  • 🧦 WebSocket protocol in Gleam

    3
    6.0k last 90 days
  • zenohex 0.10.1

    Zenoh client library for elixir.

    69
    5.4k last 90 days
  • procket 0.9.10

    Low level socket operations

    284
    5.3k last 90 days
  • mllp 0.9.11

    An Elixir library for transporting HL7 messages via MLLP (Minimal Lower Layer Protocol)

    45
    5.3k last 90 days
  • ex_dbus 0.1.4

    Elixir implementation of D-Bus

    5
    5.2k last 90 days
  • nquic 1.1.0

    QUIC transport protocol (RFC 9000/9001/9002) for Erlang/OTP 27+

    2
    5.1k last 90 days
  • shackle 0.8.0

    High-Performance Erlang Network Client Framework

    191
    5.0k last 90 days
  • sshex 2.2.1

    Simple SSH helpers for Elixir

    159
    4.9k last 90 days
  • RTMP Plugin for Membrane Multimedia Framework

    22
    4.9k last 90 days
  • Membrane UDP plugin

    7
    4.8k last 90 days
  • An Erlang implementation of multiaddr

    8
    4.7k last 90 days
  • MQTT v5 Sessions Manager

    4
    4.6k last 90 days
  • dbus 0.8.0

    A native erlang implementation of D-Bus

    58
    4.6k last 90 days
  • mcl_om 1.2.2

    PQ-only over-mesh substrate for the macula-services/mcl-* daemons

    1
    4.6k last 90 days
  • gRPC for Erlang on the livery HTTP/2 stack: server and client

    1
    4.5k last 90 days
  • modboss 0.2.0

    Modbus schema mapping with automatic encoding/decoding.

    7
    4.3k last 90 days
  • MQTT v5 packet encoder and decoder

    6
    4.3k last 90 days
  • collie 3.0.0

    🐕 Websocket client in Gleam

    18
    4.1k last 90 days
  • ex_ssl 0.21.14

    An independent Elixir/OTP TLS stack with programmable ClientHello wire profiles

    1
    4.1k last 90 days
  • erldns 12.0.1

    Erlang Authoritative DNS Server

    494
    3.9k last 90 days
  • TURN serving as an endpoint to Membrane RTC Engine. Forked from https://github.com/processone/stun

    2
    3.7k last 90 days
  • Experimental QUIC v1 transport, Initial fingerprint observation and client profiles

    1
    3.7k last 90 days
  • Web Push notifications for Elixir: VAPID (RFC 8292) and aes128gcm payload encryption (RFC 8291/8188)

    1
    3.5k last 90 days
  • Membrane TCP plugin

    0
    3.4k last 90 days